Jump to content

Saeco Rubino 200 TTT Water Problem

Recommended Posts

I have a problem with one of my Saeco Rubinos. It is the Black model, 4 hose, Software Version 14.03. Here goes.


When I transfer the beverage setup and programing using the chip, all of the beverages work perfectly except for the bin 3 (soluble). Without doing any changes to the beverage configuration the bin pumps out the soluble into bowl 2 but sends water and starts the whipper in bowl 1. Bowl 2 fills up with powder. Bowl 2 works perfectly with bin 2 (Hot Chocolate).


The first thing I tried was to adjust the sequence which was 0 0 0 0 3, I scrolled away from the 3 and tried to come back to it but the 3 was no longer available. It disappeared.


I went down to my local Saeco shop, they had never heard of this problem. I thought that my chip had possibly been corrupted so I bought a new one with the factory settings installed. I came back to my shop, installed it, and… I got the three back in my sequence but the machine continued as before to pump the soluble out of bin 3 and send the water and turn on the whipper motor for bowl 1.


So now I have run out of ideas, has anyone found a solution to this issue?

Link to comment
Share on other sites

Hey chris in bc! Thanks for the help. The vending machine support number is 815 297 9500 through Seaga here is a link to their parts page http://www.baristastore.com/home.php for your reference.

The number that you have is for home Saeco units not vending machines.

I am still in the same situation with this problem. I will update this page with a solution if I find it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...