Jump to content

AP 112 keypad


loach33

Recommended Posts

I have a replacement keypad and harness coming but I wanted to ask the question here for any further advice.

 

Noticed today that the letters on the keypad worked but when you pushed the numbers they didn't.  (All the letters and none of the numbers)  This was both in regular sale mode and also service mode.  

 

Pushed in the harness that goes from the display to the board, making sure it's not loose.

 

Checked and rechecked the buttons and it was intermittent but usually always the letters worked but no numbers. 

 

Made the call to order the parts, pushed around a little more and.....

 

Finally, I left when the ABCDE buttons worked and also the 1 2 3 4 5 buttons worked.  Anything lower than that did not however.  

 

Thought it was weird that now the bottom of the keypad doesnt work when earlier the right side didn't.

 

If I replace the keypad do you think that's it?  Any helpful hints on changing it out?  This is my only 112, never repaired things on it.

Link to comment
Share on other sites

I have a replacement keypad and harness coming but I wanted to ask the question here for any further advice.

 

Noticed today that the letters on the keypad worked but when you pushed the numbers they didn't.  (All the letters and none of the numbers)  This was both in regular sale mode and also service mode.  

 

Pushed in the harness that goes from the display to the board, making sure it's not loose.

 

Checked and rechecked the buttons and it was intermittent but usually always the letters worked but no numbers. 

 

Made the call to order the parts, pushed around a little more and.....

 

Finally, I left when the ABCDE buttons worked and also the 1 2 3 4 5 buttons worked.  Anything lower than that did not however.  

 

Thought it was weird that now the bottom of the keypad doesnt work when earlier the right side didn't.

 

If I replace the keypad do you think that's it?  Any helpful hints on changing it out?  This is my only 112, never repaired things on it.

I'd say you definitely had a bad membrane and it's good you made the call to swap it out.  Fortunately this is an easy fix as long as you tape the clear plastic buttons to the front panel before you pull the membrane, if not they'll fly all over the place and you'll have a hell of a time getting them all back in without losing any.

Link to comment
Share on other sites

I can 2nd moondog's suggestion of taping the plastic buttons to the front panel ... I made this mistake one time and it literally took me an hour to put things back together and complete the task.

Link to comment
Share on other sites

I can 2nd moondog's suggestion of taping the plastic buttons to the front panel ... I made this mistake one time and it literally took me an hour to put things back together and complete the task.

For a ten minute job !!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...