Jump to content
Pittboy26

Vending Machine Stopped Working RV-600

Recommended Posts

If someone can help me trouble shoot. I have been having horrible problems with this machine. Got there today, (Royal Vendors 660) and the dollar bill validator, Coin Mech and Refrigeration were not working. It all sounds like it works when I start it up, and machine sounds like it’s cooling but nothing works. Any tips?

 

thank you. Having so much trouble here. 

Share this post


Link to post
Share on other sites

Does the display say anything?

By everything sounds like it’s working do you mean you hear the chain homing?

Share this post


Link to post
Share on other sites

Display shows nothing. No lights on at all. Yeah, when it could be chain homing I’m not sure. Doesn’t sound like normal, but I hear it moving somewhere. 

Share this post


Link to post
Share on other sites

Did you check the fuse. It’s a black rectangle, could have been loose or popped 

Share this post


Link to post
Share on other sites

No I didn’t. I’ll have to. Where can I get a replacement? 

Share this post


Link to post
Share on other sites

I think it’s just a 3.0amp fuse. Should be able to get it at any parts store 

Share this post


Link to post
Share on other sites

If the chain and compressor are running then the main cabinet has power.  I think the Royal cold control comes thru the board so that may be why it's not cooling.  If nothing in the door is powering up then the fuze like Savend suggests, or some other problem with power getting to the door.  You might want to download the manual for your vendor and run thru the power diagram so you can check the wiring and any transformers..

https://www.royalvendors.com/customer-service/technical-info/manuals/

 

 

Share this post


Link to post
Share on other sites

I took the fuses out and when I closed the door nothing powered on but when I put the fuses back it started up but no lights. No coin mech or bill validator. Bill validator says disconnected from system. On way to Ace to get 2 new fuses to see what happens. I’m not mechanical if this doesn’t work idk what I’m gonna do......

Share this post


Link to post
Share on other sites

When you said no coin or bill I assumed you mean you had now power to them. If they are flashing diagnostic codes then you have power & the fuse will not matter. Can you tell us what brand the coin changer & bill validator are & if they are flashing any codes?  Have you unplugged the machine for 15 seconds & plugged it back in?  

Share this post


Link to post
Share on other sites

Bill Validator is Flashing twice, meaning Disconnected from System. Coin Machine is a G6XUS-BB-KO. No power whatsoever to this one. No lights or anything. The only light there is is on the back of the bill validator saying disconnected from system. Yes I unplugged for 1 minute then plugged back in. 

Share this post


Link to post
Share on other sites

Changed Fuses, no change. Sorry guys not trying to sounds weak here or anything but I’m just defeated. Guy sold me this machine for $2500 and promised it made $200 weekly and it’s been broken down  6 out of 8 weeks I’ve owned it and maybe gets $10 a week. 

Share this post


Link to post
Share on other sites

That coin mech is crap. Get an MEI CF7512 or Coinco 9302GX

Share this post


Link to post
Share on other sites

Just to make sure, on the front of the machine there is nothing on the digital display?  Coin changer is not working (no lights, display or excepting any change)? Bill validator is displaying an error code that probably means it’s fine, just turned off from either the changer or the board. It is not refrigerating either?  Did I miss anything? 
You can take a separate extension cord & plug in the compressor to it to test & make sure you don’t have a problem with the compressor. It should be plugged in on the bottom left & will look like a regular plug end. That way we can rule it out. 
If the display on the front of the machine is working then you should see a message when the door is open that says “error”.

Let us know if you see any of those things. 
 

Share this post


Link to post
Share on other sites

The coin mech should be plugged into the bill acceptor. If the bill acceptor has power and not the mech, it's either a bad bill acceptor harness or bad coin mech. 

Share this post


Link to post
Share on other sites

Coin mech is plugged into Bill Acceptor. Was working fine until recently. No savend, no light at all in front of machine. No error codes. I’ll test plug sometime this weekend hopefully had to take kiddo home. Everything was working fine until the one day I checked it the other day. Bill acceptor has light. Coin mech does not. No light display on front. Machine is not cooling but it sounds like it’s making noise back there, just not like normal. 
 

that’s everything guys to sum it up. Lacanteen I’ll look into new coin mech if I can fix the machine at all 

Share this post


Link to post
Share on other sites

If you are in a big city try finding yourself a vending tech.

 

Share this post


Link to post
Share on other sites

This is getting all over the place... some random thoughts we may have missed:  Does the coin mech have change in the tubes?  You might also want to check the door switch, if it is damaged that might account for both the cooling problem and the disconnected from machine error message.  If the machine thinks the door is open due to a bad switch it would not activate the compressor and may have the validator inactivated also. Switch could be broken from overtightening the door, or just knocked out of place so that it is not being activated properly, or have damaged wiring. 

You may want to take orsd's advise and find a good repair tech.  What area are you in?  I see your prior post about this machine was about losing pricing and having coin mech issues.   It helps to have someone who can get your machine going and also help you learn maintenance yourself.

As for here, you may want to post some pictures of the inside of the door so we can see the validator and coin mech, along with the wiring.  Something might stand out in a photo.

Share this post


Link to post
Share on other sites

Where would the door switch be? I’m in the Topeka Kansas area. I can’t find a vending machine tech around here at all. Most are in KC area and won’t come down here. (About 1 15 hours away). I’ll post some pics next time I’m there. Thank you guys so much. Light in a world of darkness!!

Share this post


Link to post
Share on other sites

Coin mech does have change - I did check that

Share this post


Link to post
Share on other sites
23 minutes ago, Southeast Treats said:

This is getting all over the place... some random thoughts we may have missed:  Does the coin mech have change in the tubes?  You might also want to check the door switch, if it is damaged that might account for both the cooling problem and the disconnected from machine error message.  If the machine thinks the door is open due to a bad switch it would not activate the compressor and may have the validator inactivated also. Switch could be broken from overtightening the door, or just knocked out of place so that it is not being activated properly, or have damaged wiring. 

You may want to take orsd's advise and find a good repair tech.  What area are you in?  I see your prior post about this machine was about losing pricing and having coin mech issues.   It helps to have someone who can get your machine going and also help you learn maintenance yourself.

As for here, you may want to post some pictures of the inside of the door so we can see the validator and coin mech, along with the wiring.  Something might stand out in a photo.

The switch makes sense, except that there isn't anything showing on the front display.  I think the compressor can be ruled out if he'll plug it in separately & see if it runs.  Though unlikely a wire pulled loose on the board or chewed in two somewhere along the way might play a role.  Come to think of it, down at the bottom lefter where the compressor plugs in, there is a mess of wires.  One of those going have come unplugged & leading to issues.  

  • Like 1

Share this post


Link to post
Share on other sites

The door switch may be in several locations depending on when the machine was made.  Look for a switch on the lower part of the cabinet on either side.   Savend is correct that the display should still work if it's the switch, but you may have more than one problem going on.

Share this post


Link to post
Share on other sites

Hey guys 

 

I sold the machine for $400. Let someone else deal with it. 
 

Thanks for all your help

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...