Jump to content

Fastcorp F631 frozen IC machine problem


Recommended Posts

Hey hey,

I'm having the damndest time repairing a 631 machine that broke down on me. I have 4 of these on my route and they've been good to me for the most part. I can repair/maintain them normally but this one is proving to be a real challenge. Forgive me for making a short story long...


Found the machine out of service one day with the error Stuck motor: Up/down--- so I started by trying the reset button which didn't seem to respond at all other then making the high pitched beep noise. I then tried replacing the up/down motor. Same error message after resetting machine. Another vendor recommended I remove the entire robot and take it to VE for repair so I did that. Unfortunately VE doesn't service this model anymore (which they informed me after keeping my part 3 days).


I desperately need this machine back in service so I removed the entire robot from one of my slower locations, rendering that one out of order too. I installed the 'stolen' robot into the original problem machine, reset it, and lo and behold same error msg!


I tried using Fastcorp's trouble shooting guide and replaced the corresponding fuse (which didn't look blown) on the power board at the bottom of the door. And here's where it gets interesting...


The machine appeared to be functioning properly and even allowed me to make a purchase....



When I opened the door and thus entered service mode all of the buttons seemed to be malfunctioning. It's like they were scrambled. For example if I pressed RESET the freezer door opened.. If i pressed BACK a quarter fell from the coin mech and if I pressed VAC the robot moved to the right... Almost as if the controls were somehow inverted. All of the functiions seemed to work but not by hitting their corresponding buttons...


My next guess is that perhaps I need a new mother board. Possibly the the one behind the silver panel at the top of the door. Or maybe a power board, which is located in the silver box at the bottom of the door. I'm hoping it's not crazy expensive as I've already spent hundreds on motors and thousands in (my) labor costs. I've seen these entire machines offered for $500....


Anybody got any ideas? Or better yet did anyone read thru all this fvckery? Either way it's a new day, a new week, and I'm not all that frustrated. Appreciate any help or advice you guys can offer. All of the local guys I've asked seem super disinterested in this ordeal...




Link to comment
Share on other sites

Your service keypad is probably plugged in wrong. Follow the ribbon and invert it where it plugs in. as for your error, it's possibly a bad connection somewhere between the up/down motor and the I/O board. Start at the motor and plug and un plug every connection until you get to the I/O board. Last resort is a RAM clear which is accomplished by powering down, turning on all of the DIP switches on the computer board, then powering up. The machine should then run you through a test exercise that you don't have to do, but it doesn't hurt. Power down, put switches back where they were and program the machine.

Link to comment
Share on other sites

My guess is the original problem is a blown fuse on the power board it is on the door under the delivery bin.


Generally the fuses blow because a mouse had been living on the board and the urine had eaten thru the copper traces and or shorted out one of the triacs that control the motors.


I think VE will repair or exchange the power board.


When the cable for the service panel is plugged in upside down the lowest button on the left will now perform the upper right function.  




Link to comment
Share on other sites

You have more patients with these things than I did. Fastcorp is a nice design but I gave up when you can not find parts and the company does not support their older machines. Good luck and hope you get it figured out. 

Link to comment
Share on other sites

I'll admit my patience was wearing thin. I have 4 of these gems left on my route and when they work I love them. I'm a big fan of ice cream...


With that said, thanks again you guys ROCK !


It's nearly impossible to get someone locally to help you with these type of issues, especially with a machine they've deemed 'obsolete'.


Long story short: The fuse was blown, the mice had shat and passed all over the Power Board, and the plug to the control pad was obviously plugged in backwards by the last vendor who tried to help me fix the problem.


Sooo... I'm back in business and I learned something new.



Thanks again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...