google.com, pub-6262331124919164, DIRECT, f08c47fec0942fa0 Jump to content
Firetad4

Royal 660-8 GIII problems “out of service”

Recommended Posts

 Just bought a used royal vendor 660-8 GIII,  I seem to have a few error codes that are inconsistent. I have the refrigeration and hot code but seems to be no problem cooling.  Thought maybe this was just from it being unplugged and/or open for so long while I was working on it.  I was having trouble with it randomly powering down which I found that the fuse in the door was rattling loose because the cover on it is missing (Secured it with a couple pieces of tape)  not sure of this loose fuse is causing a random out of service read out.  Just found the fuse problem tonight left it working and running we’ll see if that changes tomorrow.  When it would power down all the prices would reset which would point towards a bad battery. I cannot find the battery on the control board. Two other error codes that I can’t seem to find anything about including it in the manual is “nOnE” and “init”. Any and all help appreciated. 

Share this post


Link to post
Share on other sites

nOne means that there are no errors... that's what you want to see every time you open the door!

Share this post


Link to post
Share on other sites

 OK, that makes sense. Thanks 

Share this post


Link to post
Share on other sites

 Seems like a lot of my problems may have been coming from the fuse coming loose and disconnecting power. But I still don’t see a battery on the control board.  Anybody got a picture or can direct me to the battery on the control board or where it may actually be? Also, if the machine loses power and loses the memory of the pricing, will it also lose the memory of the custom column settings?

Share this post


Link to post
Share on other sites

The battery in this pic is black, but it might also be yellow. It will also have the word "timekeeper" on it.

2Wai6cQ.jpg

Share this post


Link to post
Share on other sites

Okay, thank you!  Much different than what I was looking for. Is this a battery I can get at a battery store or is it a special purchase item from the manufacturer?

Share this post


Link to post
Share on other sites

Mouser Electronics is where I get them online.

Share this post


Link to post
Share on other sites

Thanks AZ, Can you tell me if memory loss on prices would also cause memory loss on column programming?

Share this post


Link to post
Share on other sites

It is possible that a dead battery could cause the loss of STS but I'm not certain of that.  You probably will find that most settings will remain.  The prices are the most volatile since they are the one item most likely to be changed by the user.

Share this post


Link to post
Share on other sites

Alright guys,  i’ve got this machine working for the most part. But now I have tried to add in Powerade at a different price. I have it set for $2  all other selections are set for $.75.  The machine will not except more than one dollar at a time. Even though I am able to set multI prices is there a chance that the multi price function is turned off and that is what’s causing this? I just assumed if I could set different prices in the multi-price function was active.  I understand that I can go into the machine and find this out when I am with it again, but I’m just trying to get a headstart on other options if this is not the problem. Thanks in advance 

Share this post


Link to post
Share on other sites

If you can set more than one price and sell at each price then multiprice mode is already on. What model validator do you have?

Share this post


Link to post
Share on other sites

Coinco BP2BX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...